Crash at startup on Windows 7 x64

May 5, 2009 at 4:25 AM
Hi,
Windows Live Writer Backup crashes at startup on windows 7 x64 if "Live Writer" has never been started.

public static Blog[] ConfiguredBlogs()
{
    Blog> list = new Blog>();
    RegistryKey key = Registry.CurrentUser.OpenSubKey(@"Software\Microsoft\Windows Live\Writer\Weblogs", false);
}

key is null.

.m

Coordinator
May 5, 2009 at 7:42 AM
Hi, thanks for the note about that. I shall correct that in the next release.
Aug 9, 2009 at 9:29 PM

Hi

I have just installed Windows 7 RTM 64bit and I have installed WLWBackup to restore my backup. But I get this: http://www.eliasen.dk/files/wlwbackup_error.png

Not sure if this is the same error as the person who started this thread, though...

Any help?

Thanks.

--
eliasen

Coordinator
Aug 9, 2009 at 9:51 PM

Possibly not. Can you email me your logfile to wlwbackup@scottisafool.co.uk. To get to your backup, do Start > Run (or Win Key + R), then type "%localappdata%\Windows Live Writer Backup" without the quotes and press enter. In there will be your logfile.

Aug 10, 2009 at 10:07 PM

Hi

that folder does not exist on my laptop. See here: http://www.eliasen.dk/files/localapplist.png

--
eliasen

Coordinator
Aug 10, 2009 at 10:12 PM

Can you go to c:\program files (x86)\windows live writer backup\ and just tell me what version the exe is? It sounds like the problem is with writing the log file, but that should have been fixed a few versions ago. If you are having any problems, try uninstalling and downloading  3.0.0.5.

Aug 11, 2009 at 6:38 PM

Hi

http://www.eliasen.dk/files/wlwbackup_version.png

So it seems this is the right version.

I have VS.NET 2008 installed - perhaps the easy way is for me to download the source code and debug from there? Or do you have any other thoughts?

--
eliasen

Coordinator
Aug 11, 2009 at 7:07 PM

Quite possibly, yes. Although, I haven't been able to check in the changes for 3.0.0.5 yet (reinstalling all your machines can be a bitch sometimes :)), however, the change made in 3.0.0.5 shouldn't affect the startup so the chances are you might see the same problem with that version (3.0.0.4). I will be very interested in your results.

Aug 12, 2009 at 6:58 PM

Seems there is an issue with the version of subversion that codeplex is running; http://codeplex.codeplex.com/WorkItem/View.aspx?WorkItemId=24252

I have downloaded the zipped source instead and will start investigating now..

Aug 12, 2009 at 7:21 PM

Hi

I can't commpile. I went to the download page and downloaded the source zip file. I opened up the solution file and tried to build the solution.

I got this error:

http://www.eliasen.dk/files/wlw_compile_error.png

New thoughts? I have never had anything to do with WPF and I have no idea what the error means...

--
eliasen

Sep 18, 2009 at 6:54 PM

Right. Starting Windows Live Writer first and then restoring afterwards solved the issue.

Thanks.

--
eliasen

Coordinator
Sep 18, 2009 at 11:23 PM

Ah, that's good to know, thanks. I'll put some checks in to see if Writer has been run on the new system, and advise if it hasn't. Thanks for your feedback.