Restore completes but nothing happens

Apr 24, 2009 at 6:55 PM
Hi Scott,

Here's my System:

Source System:
Windows XP SP3
LiveWriter Version: Build 14.0.8064.206 en

Destination System:
Windows Vista Ultimate SP1 x64
LiveWriter Version: Build 14.0.8064.206 en

I ran the backup on the XP system and tried to restore it to the Vista system.  When the restore is completed I open Livewriter on the Vista system and nothing has been restored.  It's as if nothing was restored.

Is the problem based on the x64 vs. x86?  I'm thinking perhaps the path is messed up since Live writer is in the Program Files (x86) folder.

Thoughts?


Coordinator
Apr 24, 2009 at 11:15 PM
Hmmm, this is the second report of this scenario. I have no suggestions at the moment, but I think I'm going to have to look into this a bit. I will post here again when I have found something.
Oct 6, 2009 at 3:47 AM

I also had this problem... XP x32 backup could not be restored to a Vista x64 computer.

Nov 13, 2009 at 8:20 PM

Similar problem here. XP x86 backup, does not restore to neither Win 7 x86 or Win7 x64. I have investigated further and found that the reason is an unathorizedexception when trying to write to registry. Unfortunately you do not log which key is the problem. I have looked at all keys in the settings.xml and blogsettings.xml in the wlwbackup file. I have examined all keys with regedit, and I have Full Control permission for all. I have read somewhere that this error can occur when you forget to call opensubkey with second parameter equal to true. Could that be the case ? (Of course I run elevated to administrator, and I have tried to turn of UAC).

Nov 13, 2009 at 8:24 PM

BTW. I also noticed in the sourcecode that you make some temporary reg files at some point and use them as parameters to regedit. You do this with process.start. Will regedit run with Elevated permissions in this case ? I am not sure.

Nov 21, 2009 at 3:30 PM

Maybe it's time to phase out XP, XP sucks.  It's old hat.  With Windows 7, XP is a pile.